<< German SeaMonkey overtaking Mozilla | The roads I take... | A Big "Danke!" to Our Community >>

SeaMonkey and Lightning Calendar

Yes, what the recent Calendar blog post says is true: I did enable the Lightning Calendar to be built with SeaMonkey.

But be warned: NO, it DOESN'T WORK - currently, at least.

Recently, when the way of integrating Lightning with Thunderbird has been changed, the integration with SeaMonkey broke heavily and we still need to work on fixing that.

There are a few other things to be aware of as well:
All that said, we are happy we can cooperate with the calendar project to get some kind of calendaring support for future SeaMonkey versions, as this is a frequently requested feature and an interesting prospect for addition to our suite. Still, there's lots of work to do and lots of experience to gather - we'll see how this all works out.

Thanks to the calendar team for enabling us to work with them on this.
And if you are interested in good integration of Lightning with SeaMonkey and willing to work on patches and maintaining them - we are looking for you!

Entry written by KaiRo and posted on August 3rd, 2007 16:54 | Tags: Add-Ons, Lightning, Mozilla, SeaMonkey | 16 comments | TrackBack

Comments

Pages (2): [1] 2 >| (Entry 1-10/16)

AuthorEntry

Rupert Kolb

quote
Any news for integrating lightning into seamonkey?
I tried to install a recent lightning xpi, but my seamonkey 1.1.8 (at opensuse 10.3) didn't install it.

Rupert

Last edited by KaiRo at 2008-03-13 20:21

2008-03-13 19:01

Patrick

from USA

quote
seamonkey 2alpha + nightly lightning working
Today I installed nightly vercion and IS working "fine", I can't access the menus but everything appear to be in their place.
I'm looking for a connector to use the google calendar.

seamonkey 2 is really amazing If nightly vesion works really fine I can believe the final one.
Thanks
2008-05-01 06:30

Stefan Walther

from Mainz / Düsseldorf

quote
CIO
Hallo Herr Kaiser,

als ständiger Seamonkey-Nutzer möchte ich nur einmal vielen Dank sagen und Ihre Arbeit bezüglich Lightning unterstützen - sobald dieser läuft, werde ich ihn benutzen, Beta hin oder her.

Sie können auf mich referenzieren falls Sie mögen, bitte kurze Mail an mich.

Viele Grüße

Stefan Walther

Last edited by KaiRo at 2008-06-29 14:55

2008-06-29 03:14

John McCain

quote
AUCH MEINEN DANK UND GRÖßTEN RESPEKT!!!
Habe Mozilla/Seamonkey/Calendar über lange Jahre (seit ca. 2001) im "produktiven Einsatz" in mehreren kleinen Netzwerken (bis zu 50 User)

Wir hatten damals schon Netzwerkprofile noch im Netware Netzwerk, alles ohne Active Directory & ohne Exchange :o)))
2009-06-29 10:45

akapuma

from Marienheide

quote
Seamonkey + Thunderbird
Hallo,

ich würde mich sehr freuen, wenn es im Seamonkey wieder einen Kalender geben würde - so wie früher in Mozilla. Darf ich hoffen?

Gruß

akapuma
2009-07-29 22:43

KaiRo

Webmaster

quote
@akapuma:
Wenn unsere Pläne aufgehen, sollte Lightning mit SeaMonkey 2.0 in Zukunft nutzbar sein, hoffentlich auch schon mit SeaMonkey 2.0 Beta 2.
2009-07-30 00:43

akapuma

from Marienheide

quote
Welches Lightning?
Hallo,

die neue Seamonkey-Version 2.0b2 soll ja zusammen mit Lightning funktionieren. Doch welche Version nehme ich? Sowohl bei der 0.9 als auch bei der 1.0 pre erhalte ich Fehlermeldungen, z.B. "Lightning 1.0pre konnte nicht installiert werden, da es nicht kompatibel mit SeaMonkey 2.0b2 ist."

Gruß

akapuma
2009-09-13 19:18

KaiRo

Webmaster

quote
akapuma:
Danke, ich hab jetzut dafür gesorgt, dass Lightning 1.0pre-Version, die ab morgen erscheinen, auf SeaMonkey 2.0b2 installierbar sind.
2009-09-14 17:12

Sivaram

quote
Whew..Finally made Lightning work for Seamonkey
Whew. Finally made Lightning work for Seamonkey. Initially I thought have a nightly build of both Lightning and Seamonkey will work automatically, but have to unzip the lightning.xpi and change the following to make it work.

<em:targetApplication>
<Description>

<em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
<em:minVersion>2.0pre</em:minVersion>
<em:maxVersion>2.1a1pre</em:maxVersion>
</Description>
</em:targetApplication>

I changed the max version number to 2.1a1pre from 2.0pre, repack it and installed. Calender looks good as of now, let me use it and see for any bugs.
2009-09-15 13:30

KaiRo

Webmaster

quote
2.1a1pre is not officially supported by anything, if you're using that, be prepared that it just might stop working at any time, we will only actively look into those versions once we have 2.0 out the door.
For now, please test with SeaMonkey 2.0 Beta 2 or 2.0pre, and Lightning nightlies starting from today should work with that.

Last edited by KaiRo at 2009-09-15 15:44

2009-09-15 15:43

Pages (2): [1] 2 >| (Entry 1-10/16)

Add comment